Juil
4
2012

Configurer un routeur 3g cisco 881g


Je viens de faire l’acquisition d’un routeur 3g de chez Cisco et je vais tenter de vous expliquer la manière de le faire fonctionner avec l’opérateur Orange Entreprise.

 

Pré-requis

  • Routeur Cisco 881g
  • Une carte sim opérationnelle avec l’option Data
  • Avoir une bonne réception 3g
  • Connaitre l’apn, le compte et mot de passe et le mode d’authentification de votre fournisseur d’accès

Pour Orange entreprise :

  • Apn : orange-mib
  • utilisateur : orange
  • mdp : orange
  • Mode d’authentification : chap

 

Voici une photo de la bête :

image

Remarque : La carte est très difficile à insérer dans le routeur. Ne pas hésiter à forcer en respectant le sens bien sur. L’antenne se met sur la carte. Il y a un capuchon à retirer.

 

Configuration

 

L’interface 3G se nomme Cellular0.

Initialisation de la carte sim :

Cette phase permettra d’initialisé la carte sim pour se connecter au réseau 3G de votre opérateur.

Router# cellular 0 gsm profile create 1 apn mode utilisateur mdp

exemple :

Router# cellular 0 gsm profile create 1 orange-mib chap orange orange

Dévérouiller la carte sim :

Router# cellular 0 gsm sim unlock <yourpin>

exemple :

Router# cellular 0 gsm sim unlock 0000

Le routeur garde en mémoire le code pin même après redémarrage du routeur.

Configuration de l’interface Cellular0

interface Cellular0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer in-band
dialer idle-timeout 30
dialer string gsm
dialer-group 1
ppp chap hostname orange-mib
ppp chap password 0 orange

 

ip address negotiated –> Adresse IP apprise par le dhcp de l’opérateur

ip nat outside –> Activation du Nat

Le reste permet la communication avec l’opérateur. Pensez à modifier l’apn et le mot de passe si vous n’êtes pas chez orange entreprise.

définition de la chaine de connexion à l’opérateur :

Cette chaine est utilisée par l’interface Cellular 0 par la commande dialer string

Router(config)# chat-script gsm "" "ATDT*99#" TIMEOUT 60 "CONNECT"

Cette chaine est peut-être différentes en fonction des opérateurs

Exemple d’interface Vlan ( Réseau Interne ) :

interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
ip address 10.10.10.1 255.255.255.248
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1452

Sécuriser le flux pouvant utiliser la connexion 3G :

Router(config)# access-list 1 permit any

Router(config)# dialer-list 1 protocol ip list 1 –> Utilisé par dialer-group de l’interface Cellular0

A vous de filtrer comme vous le sentez.

 

Spécifier les flux à nater :

Router(config)# access-list 2 permit 10.10.10.0 0.0.0.7

Router(config)# ip nat inside source list 2 interface Cellular0 overload

 

Définition de la route par défaut :

Router(config)# ip route 0.0.0.0 0.0.0.0 Cellular0

Articles similaires

Au sujet de l'auteur: Olivier Legras

Auteur de ce Blog, je partage quelques unes de mes notes que je juge utile à vous comme à moi. Je suis très heureux de voir que mon blog a de plus en plus d'affluence. Merci à vous!

5 Comments + Add Comment

  • problème de fonctionnement. je n’arrive pas a le faire fonctionner chez moi.
    cela dit j’ai du pap et pas de chap comme auth sur l’APN.

    les APN orange que j’ai : orange.fr et orange.

  • Es-tu sûre de tes apn et méthode d’authentification? En tout cas, j’avais vu plein de truc sur le net concernant mes apn. J’ai appelé le service client et tout ce que j’avais vu était faux donc si tu as un doute appel les 😉

    A part ça, je ne vais pas pouvoir t’aider plus… J’en ai configuré qu’un seul et je me suis arraché les cheveux 🙂

    Bon courage

  • Est IL possible de mettre UNE carte sim dans n’importe quel emplacement (0 ou 1) sans devoir entrer de lignes de commande le jour où nous le ferons: le système détecte automatiquement une carte sim soit dans l’emplacement 0, soit dans l’emplacement 1.

  • Bonjour,

    Je souhaite mettre en place un accès 3G sur un cisco 1921 en urgence.
    J’ai suivi votre turoriel mais le profil que j’ai crée reste innactif.
    Une piste ?
    Ne manque t’il pas une configuration à faire afin de l’activer ?
    Pour information, je n’ai pas encore créer de Vlan.

    Merci pour votre aide

  • Ouh la!! J’ai pas mal galéré à me connecté en 3G mais franchement je me souviens plus de rien.
    Je vais le refaire bientôt sur un 819 en 4G. Mais vu que tu es dans l’urgence, tu ne peux pas attendre. Donc ba bon courage!
    Tiens moi au courant si tu y arrive 😉

Laissez un commentaire



Je soutiens

Publicité :)

Mes derniers tweets