Juil
17
2012

Thème WordPress utilisant Cufon – Problème d’accents


Comme vous pouvez-le constater, je viens de changer de thème. Bien sûr, seul les anciens le remarqueront.

Le thème WordPress que j’ai choisi est Alltuts. Celui-ci utilise du code JavaScript permettant d’utiliser une autre police de caractère que les polices standards ( Connues de tous les navigateurs). Par défaut, la police utilisée par mon thème ne gère pas les accents.

Voici la méthode que j’ai utilisé pour résoudre ce problème :

  1. Aller dans le répertoire de votre thème /wp-content/themes/votre_thème/js
  2. Regarder le nom du fichier police utilisé par cufon ( ça ressemble à ça Century_Gothic_400-Century_Gothic_700.font.js )
    Ceci veut dire que la police utilisé est Century Gothic. A vous de la trouver sur Internet. La police a normalement une extension en .ttf
  3. Aller sur le site http://cufon.shoqolate.com/generate/
  4. Sélectionnez la police que vous venez de télécharger

    image

  5. Décochez la case “All” puis cochez les cases comme ceci :
    image
  6. Validez accepter les conditions d’utilisation
  7. Cliquez sur “Let’s do this”
    image
  8. Vous allez télécharger un fichier .js
  9. Renommer l’ancien fichier de votre thème en ajoutant .old (Century_Gothic_400-Century_Gothic_700.font.js.old)
  10. Renommer le fichier téléchargé du même nom que celui que celui d’origine (Century_Gothic_400-Century_Gothic_700.font.js)
  11. Placez le dans le répertoire js (/wp-content/themes/votre_thème/js)
  12. Actualisez votre blog

Admirez votre nouvelle police.

Pour plus d’information, Allez voir cet article :

http://www.alsacreations.com/actu/lire/636-cufon-nouvelle-alternative-pour-intgrer-des-polices-truetype-et-opentype-au-web.html

Au sujet de l'auteur: Olivier Legras

Auteur de ce Blog, je partage quelques unes de mes notes que je juge utile à vous comme à moi. Je suis très heureux de voir que mon blog a de plus en plus d'affluence. Merci à vous!

4 Comments + Add Comment

  • Hello,

    J’ai le meme theme que toi et les memes problems d’accent.
    J’ai essayé ta procédure mais visibleme ca ne marche pas . on me dit « You didn’t confirm that you’re allowed to use the font ». Une autre solution ?

  • ça veut dire que tu n’a pas confirmé que tu as le droit d’utiliser la police. Vérifie que tu as bien coché la case correspondante.
    peut-être ça : The EULAs of these fonts allow Web Embedding

  • Bonsoir Olivier
    merci pour votre solution
    le problème avec l’accent est résolu, mais l’apostrophe ca reste encore :/

  • Merci Olivier, le problème est résolu maintenant.

Laissez un commentaire



Je soutiens

Publicité :)

Mes derniers tweets