Juin
11
2013

Agrégation de carte réseau sur Windows à l’aide de Broadcom Advanced Control Suite 4


Voici une procédure permettant d’agréger 2 cartes réseaux Broadcom sur un serveur Windows :

Avant toutes choses, vous devez être sure de pouvoir accéder en mode console sur le serveur au cas où vous ne puissiez plus y accéder à distance.

Procédure :

  • Ouvrir Broadcom Advanced Constrol Suite 4 .
  • Se mettre en team view et créer un nouveau TEAM  en mode expert puis le configurer comme ceci :

image_thumb[4]

Le type d’agrégation que j’ai choisi est le Link Aggregation (802.3ad) qui correspond au protocole LACP. Le fait d’utiliser ce protocole nécessite de configurer également les ports du Switch en Etherchannel.

Pensez à sélectionner les interfaces qui devront être ajouter au NIC TEAMING.

Si les ports du switchs sont configurés en mode trunk, vous pouvez également gérer les Vlans sur cette interface.

Il ne vous reste plus qu’à valider et configurer la nouvelle interface réseau ayant le nom de votre Team :

image_thumb[7]

 

Configuration Switch Cisco

Comme indiqué précédemment, lorsque le protocole LACP est utilisé pour le mode de bonding, il est nécessaire de configurer les ports du switchs pour que le loadbalancing fonctionne convenablement. Voici un exemple de configuration de port pour un équipement Cisco :

interface GigabitEthernet1/0/1

description Port 1

switchport access vlan 10

switchport mode access

no cdp enable

channel-group 1 mode active

spanning-tree portfast

end

interface GigabitEthernet1/0/2

description Port 2

switchport access vlan 10

switchport mode access

no cdp enable

channel-group 1 mode active

spanning-tree portfast

end

interface Port-channel1

description Agrégation 1

switchport access vlan 10

switchport mode access

end

Articles similaires

Au sujet de l'auteur: Olivier Legras

Auteur de ce Blog, je partage quelques unes de mes notes que je juge utile à vous comme à moi. Je suis très heureux de voir que mon blog a de plus en plus d'affluence. Merci à vous!

4 Comments + Add Comment

  • Salut ,

    Merci pour ce tuto, Pourquoi as-tu choisi ce mode et pas :

    Smart Load Balance and Failover
    Generic Trunking (FEC/GEC)/802.3ad-Draft Static
    SLB (Auto-Fallback Disable) – The Auto-Fallback Disable feature is configured for Smart Load Balance and Failover type teams in the Teaming Wizard.

    On dois choisir entre les différents modes et je ne sais pas trop lequel choisir.

    merci pour ton retour

  • Ouh la… Je ne me souviens plus trop mais il me semble que c’était le seul mode compatible avec l’etherchannel du switch.

  • merci pour le tuto
    en fait, j’avais déja configuré la meme chose mais ce qui me tracasse c’est qu’apres config, sur le switch mes 2 interfaces ne fonctionnent pas en simultané (une en P l’autre en s)
    *****************************************************************************
    SWITCH#sh etherchannel 10 summary
    Flags: D – down P – bundled in port-channel
    I – stand-alone s – suspended
    H – Hot-standby (LACP only)
    R – Layer3 S – Layer2
    U – in use f – failed to allocate aggregator

    M – not in use, minimum links not met
    u – unsuitable for bundling
    w – waiting to be aggregated
    d – default port

    Number of channel-groups in use: 3
    Number of aggregators: 3

    Group Port-channel Protocol Ports
    ——+————-+———–+———————————————–
    10 Po10(SU) LACP Gi1/0/11(P) Gi1/0/12(s)
    *****************************************************************************

    quand je fais de l’etherchannel entre deux switch, j’ai toujours toutes les interfaces en (P)

    est ce la meme chose pour vous ?

    ou ca fonctionne en (P) pour toutes les interfaces ?

    Merci

  • Franchement, j’en ai aucune idée, je ne me souviens même plus où je m’en suis servi 🙂 Dsl

Laissez un commentaire



Je soutiens

Publicité :)

Mes derniers tweets