Mar
20
2014

Configurer un routeur 4G Cisco 819G


J’avais déjà fait un article sur comment configurer un routeur 3G Cisco 881G  pour se connecter en 3G. A présent, je vais vous montrer comment ce connecter à la 4G avec un Cisco 819G.

Vous verrez que pour la 4G il y a quelques différences au niveau de la conf.

 

Déjà, voici une petite photo de la bête :

J’ai même eu une soucoupe volante en prime. Malheureusement elle ne me permet pas d’avoir un signal plus puissant par rapport à l’antenne fournie avec le routeur.

 

Pré-requis :

  • Routeur Cisco 819g
  • Une carte sim opérationnelle avec l’option Data (Bien vérifier que la carte ait été activée)
  • Avoir une bonne réception 4g
  • Connaitre l’apn, le compte et mot de passe et le mode d’authentification de votre fournisseur d’accès

Pour Orange entreprise :

  • Apn : orange-mib
  • utilisateur : orange
  • mdp : orange
  • Mode d’authentification : chap

 

Configuration :

L’interface 4G se nomme Cellular0.

Initialisation de la carte sim :

Note : Par rapport à la 3G, l’option gsm est remplacé par lte.

Cette phase permettra d’initialisé la carte sim pour se connecter au réseau 3G de votre opérateur.

Router# cellular 0 lte profile create 1 apn mode utilisateur mdp

exemple :

cellular 0 lte profile create 1 orange-mib chap orange orange

Dévérouiller la carte sim :

Router# cellular 0 lte sim unlock <yourpin>

exemple :

Router# cellular 0 lte sim unlock 0000

Le routeur garde en mémoire le code pin même après redémarrage du routeur.

Configuration du chat-script :

Celui-ci change par rapport à la 3G. Si quelqu’un passe parle et en connait la raison, ça serait cool…

Router# chat-script lte "" "AT!CALL1" TIMEOUT 60 "OK"

Configuration de l’interface Cellular0 et des options de ligne

Cette partie est identique que le 881G mais impossible d’utiliser l’encapsulation ppp. Seul l’encapsulation SLIP est autorisé.

conf t

dialer-list 1 protocol ip permit

interface Cellular0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer string lte
dialer-group 1
async mode interactive
!

line 3
exec-timeout 0 0
script dialer lte
modem InOut
no exec
transport input all
transport output all

Configuration de l’interface LAN + NAT

Nous sommes obligé de configurer l’interface LAN. Ici, la Vlan1 mais bon ça c’est à vous de voir. Pour valider la connexion, il faudra générer du trafic. L’interface Cellular0 s’active à la demande.

interface Vlan1
description $ETH_LAN$
ip address 10.10.10.1 255.255.255.248
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1452
!
!

L’activation
ip nat inside source list 2 interface Cellular0 overload
ip route 0.0.0.0 0.0.0.0 Cellular0
!
access-list 2 permit 10.10.10.0 0.0.0.7

Test

A ce stade, vous pouvez tester de pinger une adresse Publique ex : 8.8.8.8

L’interface Cellular0 doit s’activer.

 

Il faut vérifier que le profil est bien actif :

Router# sh cellular0 profile

 

Profile 1 = ACTIVE*
——–
PDP Type = IPv4
PDP address = 10.47.74.221
Access Point Name (APN) = orange-mib
Authentication = Unknown
Username: orange
Password:
        Primary DNS address = 193.253.141.132
        Secondary DNS address = 193.253.141.133

 

Vous pouvez vérifier la qualité du signal à l’aide de cette commande :

Router# sh cellular 0 radio
Radio power mode = ON
Current RSSI = -65 dBm
LTE Technology Preference = AUTO
LTE Technology Selected = AUTO

 

Conclusion

Pas mal, la 4G! J’ai obtenu un débit descendant de 35Mb/s ! Beaucoup mieux que mon ADSL Clignement d'œil

J’espère que cette configuration vous aidera à configurer votre routeur du premier coup. Pas comme moi…

Articles similaires

Au sujet de l'auteur: Olivier Legras

Auteur de ce Blog, je partage quelques unes de mes notes que je juge utile à vous comme à moi. Je suis très heureux de voir que mon blog a de plus en plus d'affluence. Merci à vous!

11 Comments + Add Comment

  • Salut,

    merci pour tes informations qui m’ont été bien utiles encore une fois

  • Ce fut un plaisir 🙂

  • Salut, la référence du produit est : C819G-4G-G-K9

  • Bonjour,
    Merci pour ce tuto. J’utilise le même routeur mais avec un APN SFR. A partir du routeur jarrive à faire un ping à l’adresse public 8.8.8.8 mais si je configure un Lan et que je connecte un PC dessus impossible d’accéder sur internet. Est ce qu’il y’a une commande de plus à mettre ? Merci

  • Salut Rosalie,

    Je dirais que tu as un problème de Nat (Translation d’adresse).

    Vérifie bien que tu as :
    – En globale :
    access-list 2 permit 10.10.10.0 0.0.0.7 <-- Ici, seul le réseau 10.10.10.0 avec un masque de 255.255.255.248 sera naté. ip nat inside source list 2 interface Cellular0 overload <-- Permet de masquer une ip appartenant à l'access-list 2 par celle de l'interface Cellular0 - au niveau de ton interface lan : ip nat inside - au niveau de ton interface Cellular0 : ip nat outside Bon courage,

  • Bnsr
    Est ce que on peut limiter l’accès d’une puce avec un seul routeur . Cad si on prend la même puce et on le met sur un routeur elle ne doit pas fonctionner .une manière de sécurité.
    Merci d’avance

  • Je pense qu’ il est compatible tout opérateur. Brider une puces serait plus du côté opérateur.

  • Salut, je suis complètement nouveau dans ce milieu, j’ai récupérer ce routeur par un ami qui ne s’en sert plus…
    Comment avez-vous accédé à cette console ? Je l’ai démarré, connecté a un des port RJ45 à mon PC mon firewall détecte une connexion, jusque là rien d’anormal mais quand je fais un ifconfig/ipconfig, je ne vois pas de gateway, ni même d’IP local…

  • Il te faut un câble console. Il est généralement bleu. Il te permettra de te connecter sur le routeur même si il n’est pas du tout paramétré. Tu pourras utiliser putty en mode série

  • J’ai réussit a accéder a l’interface web ! Je l’ai reset … Mais la config auto ne marche pas, une idée ?

  • J’ai réussit à y accéder en, ssh merci 😀

Laissez un commentaire



Je soutiens

Publicité :)

Mes derniers tweets