Sep
7
2016

Mettre à jour PHP 5.3 vers PHP5.6 sur Centos 6


 

Cet article va vous permettre de mettre à jour votre version de PHP en v 5.6 sur Centos 6.

Attention : Il est important de savoir que php 5.5 et 5.6 n’est pas compatible avec MYSQL 5.0 et surement toutes versions inférieur à 5.5.

Donc pensez également à mettre à jour votre serveur mysql sous peine de gros plantage de votre site WEB.

Voici la procédure de mise à jour de PHP :

Installer les repos epel et remi :

wget https://dl.fedoraproject.org/pub/epel/epel-release-latest-6.noarch.rpm && rpm -Uvh epel-release-latest-6.noarch.rpm

wget http://rpms.famillecollet.com/enterprise/remi-release-6.rpm && rpm -Uvh remi-release-6*.rpm

Activer le repo php 5.6 dans le repo remi dans le fichier : /etc/yum.repos.d/remi.repo

[remi-php56]
name=Remi's PHP 5.6 RPM repository for Enterprise Linux 6 - $basearch
#baseurl=http://rpms.remirepo.net/enterprise/6/php56/$basearch/
mirrorlist=http://rpms.remirepo.net/enterprise/6/php56/mirror
# WARNING: If you enable this repository, you must also enable "remi"
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi

Mettre à jour PHP :

yum -y upgrade php*

 

Si vous avez des erreurs de dépendances, c’est souvent à cause d’un package php obsolète. Il vous suffit de le désinstaller et l’upgrade fonctionnera.

Plus qu’à vérifier :

# php -v
PHP 5.6.25 (cli) (built: Aug 31 2016 19:26:19)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies

et ne pas oublier de redémarrer apache !

service httpd restart

Articles similaires

Au sujet de l'auteur: Olivier Legras

Auteur de ce Blog, je partage quelques unes de mes notes que je juge utile à vous comme à moi. Je suis très heureux de voir que mon blog a de plus en plus d'affluence. Merci à vous!

Laissez un commentaire



Publicité :)

Mes derniers tweets